


CS CHEATSHEET 
 

Ch 1-2 
 
REFERENCES: 
 

1. Absolute = $A$1$ à blocks rows and columns 
2. Rela>ve = A1 à does not block rows or columns 
3. Mixed à two types: $A1 à block column, row rela>ve reference A$1à block row, column absolute 

reference 
 
MAIN FORMULAE AND FUNCTIONS: 
 

• SUM à Returns the arithme>c sum of a set of numerical values. Empty cells and those containing non-
numeric values are non-considered. 

• AVERAGE à Returns the arithme>c mean of a set of numerical values. Empty cells and those containing 
non-numeric values are non-considered. 

• MAX à Returns the largest value of a numeric set. Empty cells and those containing non-numeric values 
are non-considered. 

• MIN à Returns the smallest value of a numeric set. Empty cells and those containing non-numeric values 
are non-considered. 

• ABS à Returns the absolute value of a number. The same number without the sign (posi>ve or nega>ve). 
• COUNT àReturns the number of cells in a range that contain numeric values: the cells that contains dates 

and >mes are counted. 
• COUNTA à Returns the number of cells in a range that contain data, which are not empty. Includes the 

calcula>on that contain any type of informa>on. 
• COUNTBLANK à Returns the number of empty cells in a range; those cells containing no data in a certain 

range of cells. 
• IF (logical_test,(value_if_true),(value_if_false)) à Checks if a certain condi>on set by the user is verified or 

not, and returns different values or performs different opera>ons as applicable. 
 
SORTING AND FILTERING 
 
The sor>ng and filtering func>on offers two different ways to customize the display of data in your sheet: 

• Sor$ng = enables all, or part, of the data to be organized in ascending or descending order. It is not 
possible to undo a sor>ng aZer saving. 

• Filters = show or hide informa>on in the sheet according to selected criteria. They do not change the 
general layout of the sheet. 

 
Ch 3 
 
IMPORTING DATA FROM TEXT FILES 
 

1. Open the file containing the text data à Edit à Select All > Copy. 
2. Open the Excel sheet à Edit > Paste. 
3. Organize data: 

• Select column data à Data > Text in columns > Follow conversion wizard (Delimited > Next > Select 
data delimiters > Check preview > Next > Select Des>na>on > End). 

• Format data by inser>ng separators, currencies, etc. 
 
CONDITIONAL FORMATTING 
 



• Allows the appearance of cells to be changed according to condi>ons specified by the user. If the 
condi>ons are true, the cell range is forma^ed. Otherwise, no forma_ng 

• Select the cells to which you wish to apply condi>onal forma_ng -> Home > Styles > Condi>onal 
Forma_ng > Manage Rules 

 
MAIN FUNCTIONS 
 
-Of text: 
TRIM à Removes all the spaces from a text string (except those needed to separate the single words). 
-Logical func>ons: 
AND (logical1,logical2,…) à Returns the logical value when all the condi>ons in the arguments are TRUE, that is, 
when all arguments are TRUE, and returns FALSE if one or more of the specified condi>ons are falase. 
OR (logical1,logical2,…) à Returns TRUE when at least one of the condi>ons in the argument is true, that is, when 
at least one of the argument is TRUE, and returns FALSE if all the specified condi>ons are false. 
 
NESTED FUNCTIONS 
Nested func>ons in Excel are func>ons within other func>ons. The result returned by one func>on is used as an 
argument to another func>on. 
 
COMMANDS 
Paste values à Pastes only the copied data values displayed un the cells. 
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FUNCTIONS 
 

• SUMPRODUCT (array1,(array2),(array3),…) à Returns the sum of the products of two or more arrays of 
equal size. 

• COUNTIF (range, criteria) à Returns the number of cells in a range that meet certain criteria. 
• AVERAGEIF (range,criteria,(average_range) à Returns the average (arithme>c mean) of the cells in a 

range mee>ng certain criteria. 
• SUMIF (range,criteria,(sum_range) à Returns the sum of cells in a range that meet a certain criteria. 

 
COMMANDS 
  

• SUBTOTALS à It is possible to automa>cally calculate subtotals and overall totals in a list for a column à 
Data > Structure > Subtotals: 
Subtotals: with the subtotals tool, we can automa>cally insert some func>ons into a list, such as SUM or 
AVERAGE, in order to calculate par>al totals for groups of homogeneous data. 
Overall totals: derived from detail data, not form the values in the subtotals (EX: if the Average summary 
func>on is used, the overall total row displays an average of all detail rows in the list, not an average of the 
values in the subtotal rows). 

• REMOVE DUPLICATES à Select the cell range containing the duplicate values to be removed. Choose Data 
> Remove duplicates > select or deselect columns in which to remove duplicates > OK. 

 
CONDITIONAL FORMATTING WITH FORMULA 
 

1. Select cells to be forma^ed.  
2. On the home tab, click condi>onal forma_ng > New rule. 
3. In the style box, click on Classic. 
4. In the Classic box, select the op>on Format only first or last values and replace it with use a formula to 

determine the cells to be forma^ed. 
5. In the next box, type the formula. 



6. In the Format with box, click on custom format. 
7. Choose OK to close all dialogue boxes. 
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MAIN FUNCTIONS 
 

• PMT (rate,nper,pv,(fv),(type)) à Calculates the periodic payment (installment) for a loan or a mortgage 
based on constant payments and a constant (fixed) interest rate. 

• RATE (nper,pmt,pv,(fv),(type),(guess)) à Returns the interest rate for a loan or mortgage with known term 
and constant installments. It is reciprocal of the PMT func>on and iden>fies the fixed interest rate that 
leads a mortgage with given principal and term to have a certain constant installment. 

• FV (rate,nper,pmt,(pv),(type)) à Computes the future value of an investment based on periodic payments 
and a constant (fixed) interest rate. It computes the amount obtained at the end of the investment, aZer 
all the periodic payments have been invested at a fixed interest rate. 

 
COMMANDS 
 

• Transpose à paste with a 90-degree rota>on. 
• Forecasts à Data > Forecasts (Calculate or predict a future value using exis>ng values); 
• Target Search à Data > Data Predic>on > Target Search à allows you to determine which value to enter 

in an input cell to obtain the desired result in a cell containing a formula. 
• Assigning a name to a cell à To assign a name to cells in Excel, you must select the cell or set of cells to 

be named and go to the Formulas tab of the ribbon. 
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MAIN FUNCTIONS 
Text func>ons: 

• RIGHT (text,(num_chars)) à Returns the rightmost character(s) of a text string. 
• LEFT (text,(num_chars)) à Returns the the first characters in a text string, based on the number of 

characters specified. 
• MID (text,start_num,num_chars) à Returns a specific number of characters from a text string, star>ng 

from a specified posi>on. 
• UPPER (text) à Convert all the characters of a text string in UPPER case. 
• LOWER (text) à Convert all the characters of a text string in lower case. 
• CONCATENATE (text1,(text2),(…)) à Joins two or more text strings in one text string. The text is joined 

following the order of the arguments, and possible numerical values are also converted into text. 
• LEN (text) à Returns the number of characters in a text string. The spaces in the string of text, including 

any consecu>ve spaces are treated as any other character. 
• SEARCH (find_text,within_text,(start_num)) à Locates the posi>on of the first character of a text string 

within a second text string. 
• PROPER (text) à Converts the first le^er of each word of the text string into uppercase, while conver>ng 

the other le^ers into lowercase. 
Example: “MARIO ROSSI” à EXTRACT “ROSSI” à =RIGHT(no.cell,LEN(no.cell)-SEARCH(“ “,no.cell)) 
 
Sta>s>cs: 

• COUNTIFS (criteria_ramge1, criteria1,(criteria_range2,criteria2),(…)) à Counts the number of cells in a 
range that sa>sfy one or more criteria. 

• SUMIFS (sum_range1,criteria_range1,criteria1,(sum_range2,criteria_range2,criteria2),(…)) à Returns the 
sum of cells in a range that meet one or more criteria simultaneously. 

• AVERAGEIFS (average_range,criteria_range1,criteria1,(criteria_range2,average_range2,criteria2),(…)) à 
Computes the average (arithme>c mean) of all the cells that meet one or more criteria. 



 
COMMANDS 
• Data validaJon 

1. Select the cell(s) for which you wish to create a rule à Data > Validate Data. 
2. On the Se_ngs tab, select an op>on under Allow and a condi>on. 
3. Set the other necessary values according to the op>on chosen under Allow and Data. 
4. Select the input Message tab and customize a message that users display when entering data. 
5. Select the Show input message when cell is selected check box to display the message when the user 

selects or posi>ons the mouse pointer over selected cells. 
6. Select the Error Warning tab to customize the error message and choose a Style. 
7. Select OK. At this point, if the user tries to enter an invalid value, an error message is displayed with the 

customized message. 
 
 
PIVOT TABLES 
Given a table divided into rows and columns, I must have: 
1. In the first line a header 
2. First complete row (NO empty columns or columns without header). 
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Important differences protect folders/files. 
To remove 'protect workbook' simply remove (literally delete) the asterisks. 
Levels of protec>on: 
1. Sheet protector 
2. Protect folder 
3. Protect folder when opening 
 
VLOOKUP (lookup_value,table_array,col_index_num,(range_lookup)) -> Looks for a specified value in the first 
column of a table and returns a value corresponding to the one sought, available in another column of the same 
table. 
The table is sorted in ascending order by default. 
• value = code to search 
• Matrix table à cells to search in 
• Index à column number to be returned 
• Interval à insert 
TRUE: imprecise correspondence à to be used in case the value I want to search for needs to be searched for in 
groupings of values (e.g. discount ladders). 
FALSE: exact matches I search for a code and it returns the value corresponding to that code If you do not enter 
anything it comes out true. 
 
VLOOKUP is no good in a table where the same code is repeated several >mes, as it would then return an error. 
 
MATCH (lookup_value,lookup_array,(match_type)) à Searches for a specified value in a range of cells and returns 
its posi>on in the same range. 
That posi>on must be entered as an 'index' in the VLOOKUP (Returns the rela>ve posi>on of an array element that 
matches a specified value in a specified order). 
• Value 
• Array à header in which to count (must have the same cells as the VLOOKUP) 
 
If it says that VLOOKUP the index should automa>cally appear, then it means that MATCH should be used. 
Arrays of VLOOKUP and arrays of MATCH must always be the same. 



 
RANK.EQ (number,ref,(order)) -> Returns the rank of a number in a list of numbers. The result of the RANK.EQ 
func>on is a number indica>ng which rank has a specified number chosen by the user in a list of numbers sorted in 
ascending or descending order. 

 
MACRO 
Create a macro: 
1. Change format à FILE > Save As > Workbook with macro ac>va>on... 
2. Check from protec>on center. “Disable all macros with no>fica>on”. 
3. View > Record macro > Complete data > OK (you cannot enter spaces, but _; first le^er character (the small 
square at the bo^om leZ indicates that you are recording). 
4. Click on sheet tab (if there is more than one sheet). 
5. Check hidden cells. 
6. Whatever you do now, ac>ons will be recorded 
7. Stop recording: 
1. View > abort 
2. Click on the small square in the bo^om leZ-hand corner. 
 
Display recorded macros: 
View > View Macros > Edit 
Using the macro: 
View > View Macros > Run 
 
FUNCTIONS 
 
DAY (serial_number) à Return the number of the day related to any serial number corresponding to a date. 
MONTH (serial_number) à Return the number of the month related to any serial number corresponding to a 
date. 
YEAR (serial_number) à Return the number of the year related to any serial number corresponding to a date. 
HOUR (serial_number) à Return the number of hours rela>ve to any serial number corresponding to a >me or 
date. 
MINUTE (serial_number) à Return the number of minutes rela>ve to any serial number corresponding to a >me 
or date. 
SECOND (serial_number) à Return the number of seconds rela>ve to any serial number corresponding to a >me 
or date. 
WEEKDAY (serial_number,(return_type)) à Returns the day of the week corresponding to a date. The syntax of 
the func>on has two arguments; the first one is required while the second one is op>onal. 
DAYS (end_date,start_date) à Returns the number of days between two days. The syntax of the func>on has two 
arguments, both required. 
TODAY () à Return the serial number corresponding to today’s date. This number is automa>cally displayed in 
date format. TODAY func>on returns only the date. The syntax has no arguments. 
NOW () à Return the serial number corresponding to today’s date. This number is automa>cally displayed in date 
format. NOW func>on returns the date and the >me. The syntax has no arguments. 
DATE (year,month,day) à Returns the serial number that represents a specified date for which you know the day, 
month and year. This func>on is useful especially on two occasions: 1) When you have the year, month and day in 
three different cells of the worksheet, and you want to combine the values to create a full date. 2) When you have 
a date in a format that Excel does not recognize, such as yyyymmdd, and want to convert it to a serial number 
accepted and managed by Excel. 
DATEDIF (start_date,end_date,interval) à Computes the difference between two dates in days months or years. 
The syntax of the func>on has three mandatory arguments. 



IFERROR (value,value_if_error) à Performs a specific opera>on or reurns a value defined by the user when a 
formula or a func>on returns an error. The syntax of the func>on has two arguments, both required. 
 
 
SHORTCUTS 
BOLD à Ctri + B 
COPY à Ctri + C 
CREATE A NEW WORKBOOK à Ctri + N 
CUT à + Ctri + X 
DOWN ONE CELL à Enter 
OWN ONE SCREEN à Page Down 
FIND à Ctri + F 
HIDE SELECTED COLUMNS à Ctri + 0 
HIDE SELECTED ROWS à Gtri + 9 
ITALICS à C> 4 1 
LEFT ONE CELL à ShiZ + Tab 
MOVE BETWEEN CELLS à (<-; ->) 
OPEN A WORKBOOK à Ctri + O 
PASTE à Ctri + V 
PRINT A WORKBOOK à Ctri + P 
REDO à Ctri + Y 
REPLACE à Ctri + H 
RIGHT ON CELL à Tab 
SAVE A WORKBOOK à Ctri + S 
SELECT ALL à Ctri + A 
SELECT ENTIRE COLUMN à Ctri + Space 
SELECT ENTIRE ROW à ShiZ + Space 
TO CELL A1 à Ctri + Home 
TO LAST CELL à Ctri + End 
UNDERLINE à Ctri + U 
UNDO à Ctri + Z 
UP ONE CELL à ShiZ + Enter 

ERROR TYPES 
 
ERROR #### (…) Among Excel errors, this message does not signal a problem with the formula, 
unless it is the result of an opera<on between dates. The con<nuous # symbol (hash mark or 
hashtag call it what you like) signals insufficient space on the column. On the other hand, when 
the formula includes serial date/<me numbers, it indicates that the result is nega<ve and 
therefore not representable. 
 
ERROR #NUM!  This error also iden<fies a problem of width, not physical but logical. The 
#NUMI error occurs when using numeric values that exceed Excel's limit. The current version 
allows you to enter numbers between -10^308 and 10^308. 
 
ERROR #RIF! 
This error occurs when rows or columns that have references within the formula are deleted. 
Example: The cell with formula A1+B1 will return the error #RIF! aXer dele<ng column B. 
 
ERROR #VALUE! 



When the data types of a formula's references do not match (e.g. a number added to a leZer), 
the #VALUE error occurs/The same problem occurs when the arguments of a func<on do not 
match the required data type (e.g. numb. or value). sum product when matrices have different 
dimension. 
 
ERROR #DIV/O! 
This error code is generated when the formula contains a division with a divisor equal to zero. 
The #DIV/O! error also occurs when the divisor reference leads to an empty cell.  
 
ERROR #NAME is returned when using non-existent func<on names (or with incorrect syntax) 
or incorrect range names. In the laZer case, the incorrect name is placed between double 
quotes. 
 
ERROR #NULL! 
The error code #NULLI occurs when a range is given without the correct separator. Example: 
COUNT (A1 B1). Here the colon symbol has been omiZed to indicate the start/end of a cell 
range. Or the semicolon symbol to separate two different ranges. 
 
ERROR #N/A! This code is typical of func<ons to search for values within an array (e.g. 
VLOOKUP, HLOOKUP MATCH, etc.). 
When the value is not present, the error #N/A! is returned, which means Not/Available. 
 
 


